Not able to build the latest code changes on the expo app.

I upgraded my react-native and expo libraries and I also updated the Expo Android App, but now when I make a code change in my editor, and through my terminal I run the “expo start” command ,and scan the QR code inside my Expo App, I do not see my app getting updated. Is there some issue with the latest changes in the expo?

Expo CLI 3.21.13 environment info:
OS: macOS Mojave 10.14.6
Shell: 3.2.57 - /bin/bash
Node: 12.14.1 - /usr/local/bin/node
npm: 6.14.4 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Xcode: /undefined - /usr/bin/xcodebuild
expo: ~37.0.3 => 37.0.7
react: ~16.9.0 => 16.9.0
react-dom: ~16.9.0 => 16.9.0
react-native: => 0.61.4
react-native-web: ~0.11.7 => 0.11.7
expo-cli: 3.21.13

Hey @shikher123,

Is this occurring with every Expo project you’ve tried in the client or just the current project you are working on?


Yes, I created a new project with expo init command, and when I scanned the QR code of that new project, I still get the screen of my previous project. And nothing appears from the newly created project.

Got it. Can you try clearing your caches and see if that helps at all? Running expo start -c will clear the metro bundler cache.

Have done that multiple times, but no result.

Roger that. Can you take me through the exact steps you are doing to not see any changes?

I’ve opened up multiple projects and haven’t been able to reproduce the issue. Just had another thought, is there a chance you disabled Fast Refresh in the developer menu?

From where can I enable " Fast Refresh" option?

Depending on what your settings are, you’ll either do a shake gesture or a two-finger force press to open up the Dev Menu and then you’ll see an option that will say “Enable Fast Refresh” or “Disable Fast Refresh”.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.