No Web Preview in snack

I can preview on Android and IOS but not on WEB !!!

Hi. What is the SDK version of the snack? It would have to be at least SDK 33, but preferably SDK 34 (or if you wait a week, SDK 35 :smile:)

In future it would help if you posted a link to the snack that you were having problems with.

Hi Michael,

I’m using SDK 33, and same problem with SDK 34 ;

Knowing that the editor says « No Errors » !!!



Please post a link to a snack that has this problem.

Hi ,

Here goes the link for a test of snack :


R. Ko

hmmm… I’m not sure if Amazon S3 is having trouble at the moment, but if I create a new snack and just try to preview it it seems to take forever to try loading the JavaScript etc. It did eventually work, though.

This is the preview link for your snack:

If I try to load it while I have the browser’s developer console open I get some CORS-related errors, which may or may not be related to the reason your snack doesn’t show anything in the web preview.

Maybe try starting with a really simple snack and make sure that previews correctly. Then start adding things to it a little at a time. Then if it is a problem with the code you should be able to see which piece of code is causing problems. If it’s just something to do with S3 being slow at the moment then I suppose you should try again a bit later.

Hi again,

Well I already tried what you are suggesting; i.e isolate code in comments and try ;

yet this did not help, I even went to older code versions that used to work, but no luck.

At a certain moment there was un update that snack asked to Apply (which I did) , I do not know

If this is related or not, that is why I tried V34 yet same problem. Remind you that

All is well on the Android or the Ios emulators !!!


R. Ko

I’m having the same issue. Expo asked if I wanted to update, so I did it. No more web preview after that.

Hi Michael,

Today I have a new problem :

All the saves of my project on snack since yesterday and before are lost,

The latest save that I have dates from 19/09/2019.

Project :

How can I fetch the save of my project for 26/09/2019 !!!


Rm Ko

Hi @rmko. Someone from the Expo team will have to have a look. They did help a couple of people with a similar problem recently.

Hi @jkhales, could you have a look?

I’ve noticed that snacks I save also don’t always show up on

Hi again,

For some Reason it is back and working, I was able to pick back the

Save of esterday 26/9/19 and all is well.

Thanks anyway for your help.


Rm Ko


Happy everything is working again! Thanks for helping them through this @wodin!

1 Like

I’m having the same problem with web preview, doesnt work at all

  • running in v 35
  • Cors errors in browser’s console
  • others emulators are working well

some ideas ?

cors errr

Access to fetch at '' from origin '' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. If an opaque response serves your needs, set the request's mode to 'no-cors' to fetch the resource with CORS disabled.

Can you share the snack?

here you have


@gustavoq.ic Should be resolved. Thanks for letting us know!

1 Like

excellent, looking forward for the fix


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.