No developer menu on Android

I’m trying to debug my app in vscode and it says to go to developer menu on the expo app and choose debug is remotely

Shaking the app doesn’t do anything

How can I see the menu?




Make sure you’re not in “production” mode.

Also, I have found in the past that I had to shake quite hard for it to show up on my phone. Not sure if that will help for yours.

There’s also the possibility that your accelerometer is not working (although I don’t know how likely this is). You could try something like this, but be careful and you might have to restart your phone to get out of some of the options :laughing: Otherwise maybe try one of the sensor test apps.

There’s a comment here about settings in the Expo client and using a two-finger touch, but I believe that’s only for the iOS version of the client.

The documentation implies that this is only for “virtual” Android devices, but I’ve just tried it on a physical phone and it works for me. Run the following:

adb shell input keyevent 82

In case you don’t know how to do this, the following might help:

Make sure USB debugging is turned on on the phone. Then plug the phone into your computer and accept any “do you want to trust this computer” type prompts.

expo-cli comes with a version of adb that it uses internally, so it’s probably best to use that one. For the machine I tested on I found it here, but you might need a macOS or Windows version:


I added it to my PATH as follows:

export PATH=/usr/local/node-v12.6.0-linux-x64/lib/node_modules/expo-cli/node_modules/@expo/xdl/binaries/linux/adb:$PATH

Hi everyone!
For those who will face the issue - Try a restart of your device, seriously :slight_smile:
I’ve shaked my phone as crazy, but it hasn’t worked. But after the restart, the menu was opened easily.