New update available, downloading

-Edit: I find the solution. Look bottom.-

I have been researching for three days but I couldn’t find a solution. I am developing a react native app with expo on windows 10. I cannot continue to develop the project for this case, thank you for your help. I tried things for fixing:

  • I tried on another operating system (Arch Linux on the USB stick, same machine.) for the same project. It is building and downloading the app to expo go on android device.

  • I tried deleting package-lock.json, node_module, npm cache clean --force, and npm install - not working

  • I tried npm uninstall -g expo-cli and npm install -g expo-cli - not working

  • I tried deleting all project folder and re-clone from GitHub and trying expo start - not working

  • I tried node and npm and reinstall. - not working

  • I tried creating a new expo project with expo init - not working. (But I tried the init expo project on another operating system. It is working.)

  • I almost forgot. I tried to click “Run in web browser” and it is working!1!11!.

  • I tried also it on the android emulator. - not working

  • I tried adb reverse tcp: 8081 tcp. 8081 on windows and on wsl - not working

  • I tried installing open_ssl and watchman for the flipper. Maybe open_ssl or watchman problem for connecting. I remove them but not working still.

My npx expo-env-info

  expo-env-info 1.0.3 environment info:
      OS: Windows 10 10.0.19044
      Node: 16.15.0 - C:\Program Files\nodejs\node.EXE
      npm: 8.7.0 - ~\AppData\Roaming\npm\npm.CMD
      Watchman: 20220416.121541.0 - C:\ProgramData\chocolatey\bin\watchman.EXE
      expo: ^44.0.0 => 44.0.6
      react: 17.0.1 => 17.0.1
      react-dom: 17.0.1 => 17.0.1
      react-native: 0.64.3 => 0.64.3
      react-native-web: 0.17.1 => 0.17.1
      react-navigation: ^4.4.4 => 4.4.4
    Expo Workflow: managed

Edit: Hello I find the solution thanks to God. I remove open ssl and watchman before but not completely deleted them. I found them folders path from the system environment “path”. I installed watchman from chocolatey, open ssI forgot. but find the paths. I delete them and success.
I hope it will be of use to you if you have gotten into an unbearable situation.