Network timeout when scanning QR code

I’m working on my first React Native app using Expo. However, I’m having trouble scanning the QR code on my Android phone; I keep getting the error Could not load exp:// Network response timed out on both a residential building and university network. I know very little about network configuration or troubleshooting. How do I fix this?


Hi there

  1. Did you try on iOS? Have access to an iOS phone?
  2. Have you tried again lately?
  3. You can also develop on the simulators, XDE has the ‘device’ button on the right side and you can open in iOS simulator if on a MacBook, or android if you have the android emulator already running.

Thanks. I don’t have access to an iPhone, unfortunately. :frowning: And not sure if I can run a recent version of XCode/iOS simulator on my machine; it’s pretty old. No idea about the Android emulator. I’ll look into those, but I was really hoping to get Expo working; it seemed like the simplest solution.

Expo is the simplest solution i think, so getting the QR code working would be great. Do you have any kind of special setting going on in your wifi for those networks you’re using? Some kind of proxy or anything? Try some more networks.

Android Emulator will require installing android studio, if using brew then recommend: brew cask install android-studio

No special setting that I know of; it’s a semi-public building wifi (no credentials required). If there are proxies, I don’t know about them.

I’ve also tried a local public university network. Same problem. I know very little about networking, so I’m not sure what else to do or what to fiddle with.

Will try installing Android studio. I was under the impression that Expo was a plug-and-play solution on mobile, but apparently not. An internet search sent me to the XDK, which recognized my project and gave me the warning Warning: Not using the Expo fork of react-native. See So now I’m looking into that, as well as installing Genymotion. I’m not really sure how to put these pieces together.

I’m super-new to development, so this is all pretty confusing. Lots of rabbit holes to run down. :slight_smile:

  1. I meant on your phone itself, sometimes you can change Wifi settings per wifi networks.
  2. Expo ya is plug and play, it is not necessary to have a Mac or simulator, but having that be an option is good as well.

Not sure what XDK is, Genymotion is just another emulator, it is not necessary to have since Android Studio gives you the android emulator.

Ask as many questions! Welcome to coding :smile:

Oh, I see. Yes—I tried both networks on both my laptop and phone. Same problem both times.

XDK is the desktop counterpart of Expo: I’m walking through the Android simulator installation instructions there. Many deep rabbit holes. :slight_smile:

1 Like