Native package repeatedly asks for permission/does not save accepting them

I followed this tutorial to use native packages with EAS

I installed react-native-record-screen and updated the permissions as it says to in the README. Every time I restart the app, it asks for permission to record the screen. I can’t get them to save.

Reproducible demo or steps to reproduce from a blank project

1 Install package
npm install react-native-record-screen

2 Add to App.js

import RecordScreen from "react-native-record-screen";

const stopRecordingThisCrap = async () => {
    const res = await RecordScreen.stopRecording().catch((error) =>
    if (res) {
      const url = res.result.outputURL;

    <Button onPress={() => RecordScreen.startRecording().catch((error) => console.error(error));} />
    <Button onPress={() => stopRecordingThisCrap }

3 Add lines to pod file and androidmanifest laid out here (I’ve tried with and without these and same result)

4 EAS build preview for ios

5 Open app > Press button for screen record > Accept permissions > Press button for stop record > Fully close out app > Reopen app > Press button for screen record to see if it requests permission again