My Expo Managed workflow project suddenly became bare workflow

Hi everybody, here i am again with a new surprise.
it turns out that today, while trying to build my expo managed app, i got this message ( expo build:android currently only supports managed workflow apps.) and you know, my reaction to this was (WTF!) because my project was a managed workflow and then suddenly became bare workflow and i never ejected it.

So, i think this happened after upgrading to Expo SDK 39, but again, i never ejected my project.
i remember that i had some problems with some pods right after upgrading but i managed to solve it.

So, what happened? has someone faced this as well?

Hi. Could you explain what you mean by this?

Hi, yeah, right after upgrading to SDK v39, i tried to run my app using the Expo Client for android and i got some errors related to pods, these two lines from Podfile to be clear:

  pod 'ReactCommon/callinvoker', :path => "#{rnPrefix}/ReactCommon"
  pod 'ReactCommon/turbomodule/core', :path => "#{rnPrefix}/ReactCommon"

it was something related to a conflict with these files version, but before that, i don’t remember this file or getting these errors. so i decided to search in google and found a solution which worked out (i don’t remember the command, but it wasn’t expo eject), but at that moment i didn’t try to rebuild my app until now. What could be happening?

There shouldn’t be anything to do with pods/Podfile if you have not ejected. You also should not have an android directory or an ios directory.

So maybe the project was ejected some time in the past, but the Expo tools just started warning you about it now?

Anyway, if I were you I would move the android and ios directories out of your project and then create a new Expo project and compare the app.json, package.json and the other default files with what you have in your project.

So well, i had to create a new project and move all my code to this new one to solve it!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.