My eas-cli seems to be installed by Homebrew, although there is no Homebrew eas-cli package!?

This seems very strange. Today I noticed that whenever I ran eas, the tool warns me that it is outdated:

★ eas-cli@2.1.0 is now available.
To upgrade, run npm install -g eas-cli.
Proceeding with outdated version.

So I run npm install -g eas-cli, which runs fine. However, EAS still tells me it is outdated.

So I run which eas, and I get /opt/homebrew/bin/eas.

Which is strange, because I never installed EAS via Homebrew (and AFAIK there isn’t a Homebrew package for it).

Any idea? How can I restore the npm EAS so I can update it? Of course I tried to uninstall and re-install it using npm, but I still have the 1.2.0 version of Homebrew.

Thanks for any hints!

I did a mv /opt/homebrew/bin/eas /opt/homebrew/bin/eas_, which solved the issue.

Still curious about how this could happen in the first place.

I think you’ll find that the one in /opt/homebrew/bin is a symlink to something under a NodeJS installation that was installed by Homebrew.