Modules available in Snack

would be nice to support glamorous-native

Would it be possible to have in Expo Snack :smiley:

@louisjs Haven’t taken it all the way, but it seems like yes:

@davidgortega Sorry, I knew we were working on getting canvas support into Expo and assumed that would be caught up by the same issues.

Sometimes modules will have a peer dependency that the module author assumes will be available and doesn’t explicitly list. You’ll now get a message saying Failed to install module 'x': Attempted to import missing module 'y' and you can resolve for yourself by importing the missing dependency (in this case regenerator-runtime)

I am getting this error:
Device: (1:0) Error loading dependency: Error: Failed to install module 'native-base': Attempted to import missing module '@expo/vector-icons/Ionicon'

Link to my snack:
Am I missing something?

You have a circular dependency in TodoService, but that’s a very strange error for us to display!
Also, Firebase doesn’t like being reinitialized, which snack does very often, so you need to wrap the initializeApp call in a try catch:

hi Expo
I’ve faced this kind of issues

Failed to install module ‘react-nav’: Attempted to redefine property ‘transition’.
imported from null

can anyone explain about above issues pl?

It’s a lot easier for people to help if you can share the link to your snack.
It looks like you are attempting to use the ‘react-nav’ module, which is failing when the app tries to load it.
We generally recommend using react-navigation for navigation. If that’s what you were trying to use, snack’s automatic imports will sometimes pull in things that aren’t what you intended if you pause while typing the import :open_mouth: There isn’t a way to resolve that situation in the UI right now, but we’ve been working to make that better and it will be available very shortly.

Hi guys, I can’t use taobao’s GCanvas. Here is my link

The issue is that the native libraries are not available right?

Oooh, looks nice.
But yes, snack will only work with pure JS libraries & native code in RN or Expo


I am experiencing errors with react-navigation v2.14
Here is a link to my project

Thanks for your help!
Also is there a master list where I can see modules / packages that expo currently supports along with their versions?


I am facing an error regarding react-native-svg. The error message is: Failed to install module ‘react-native-svg’: Failed to download module ‘react-native-svg@Supported builtin module’
imported from null. What should I do to solve it? My snack link is react-native-svg-charts - Snack

Just delete “react-native-svg” from your package.json. It’s builtin module.

I was wondering if you had any ideas for my error:

Device: (78:20) (0, _reactNavigation.createStackNavigator) is not a function. (In '(0, _reactNavigation.createStackNavigator)({ Home: _LandingScreen2.default, List: _PokeList2.default }, { initialRouteName: 'Home' })', '(0, _reactNavigation.createStackNavigator)' is undefined) Evaluating module://App.js Loading module://App.js

Also here is a link to my project:

@swkane It’s often worthwhile to try upgrading to the latest SDK if you run into issues. - Snack

That fixed it! Thanks for the tip. I will be sure to add that to the mental debugging checklist.

Hi, I am getting error while using validate.js.

Here is a snack

Can someone please help.


Hi is really cool, like the interface and ease of use to start using react native. Nice work :slight_smile:

Using and added an import for ‘react-native-elements’ and tried to run but gave following error:
Device: unable to resolve ‘module://react-native-elements’
The package.json has dependency for react-native-elements
Tap deploy to expo cloud.

The strange thing, it seems to be inconsistent error, deployed the app to cloud and 2 out of 3 times get “unable to resolve module” but there was one case where it worked fine. Seems like not all modules are being loaded onto cloud server.

Is react-native-elements supported in snack? Is there a configuration that I’m missing?


@hchin snack has a few modules pre-bundled which show up in the auto-complete when you’re writing the import.

Third-party dependencies such as react-native-elements which aren’t bundled by default can be used by adding them to the package.json file. When you import such a module, we prompt you to add it to package.json automatically, however you can also add it manually. If you don’t add it to package.json, you’ll get the “unable to resolve module” error.

Are you getting the error even after adding the dep to package.json? If yes, will be great if you can post the link to the snack where you get this error so I can take a look at what’s wrong.

I’m trying to make a minimal repro of an issue that I’m experiencing, but it looks like is unable to resolve one of the dependencies I need (react-native-blurhash).

I get this message that never goes away:

Here’s my snack: Hello Expo - Snack