Module JSTimersExecution is not a registered callable module (calling callTimers)

I keep getting this error when launching a new project. I m running version 20 of the sdk.

“name”: “styledemo”,
“version”: “0.0.0”,
“description”: “Hello Expo!”,
“author”: null,
“private”: true,
“main”: “node_modules/expo/AppEntry.js”,
“dependencies”: {
“expo”: “^20.0.0”,
“react”: “16.0.0-alpha.12”,
“react-native”: “

This is my package.json.

“expo”: {
“name”: “styledemo”,
“description”: “An empty new project”,
“slug”: “styledemo”,
“privacy”: “public”,
“sdkVersion”: “20.0.0”,
“version”: “1.0.0”,
“orientation”: “portrait”,
“primaryColor”: “#cccccc”,
“icon”: “./assets/icons/app-icon.png”,
“loading”: {
“icon”: “./assets/icons/loading-icon.png”,
“hideExponentText”: false
“packagerOpts”: {
“assetExts”: [“ttf”, “mp4”]
“ios”: {
“supportsTablet”: true

And this is my app.json file.

I hope somebody can help me.

Do you have the code for this project somewhere? Can you reproduce it using It’d help us a lot to be able to look at an example of what’s going wrong.

This is happening to me. I’ve got an expo app since earlier this year and has always worked. Now, sdk20 creates this error for me on Android, immediately upon startup. I tried removing all code from App.js and it still happens.

Same Issue
S.O: Ubuntu 16.4, virtual device by Genymotion, package.json
{ “name”: “betsapp”, “version”: “0.1.0”, “private”: true, “devDependencies”: { “jest-expo”: “~20.0.0”, “react-native-scripts”: “1.3.1”, “react-test-renderer”: “16.0.0-alpha.12” }, “main”: “./node_modules/react-native-scripts/build/bin/crna-entry.js”, “scripts”: { “start”: “react-native-scripts start”, “eject”: “react-native-scripts eject”,
“android”: “react-native-scripts android”, “ios”: “react-native-scripts ios”, “test”: “node node_modules/jest/bin/jest.js --watch” }, “jest”: { “preset”: “jest-expo” }, “dependencies”: { “expo”: “^20.0.0”,
“react”: “16.0.0-alpha.12”, “react-native”: “^0.47.0”, “react-native-elements”: “^0.16.0” }}

I had the same issue and got it sorted by removing the expo app from the simulator and running exp android to have it installed again. Hope this helps :slight_smile: