Module AppRegistry is not Registered in Standalone Android App

Hi, I build a standalone app for android, but unfortunately it failed to load as it showing the Module AppRegistry is not a registered callable module (calling runApplication) error!

I did check the logcat and saw some of the library seems to failed to load. Here is the image from my logcat.

The app is working great in my local dev and also published expo. The problem only exist when I used apk produced on my phone. Any insights and help are Kindly appreciated!!

Hi @homsdev!

What device are you running on when you get the error?

I believe this is related to Android not providing a 64-bit version of the native code, which results in the " not found" message.

Hi @charliecruzan, thanks on your reply,

I’m running it on Huawei Nova 2 i. I also tested on google pixel emulator and I got same error. Here is the error shown to me.

Yeah, unfortunately “Module AppRegistry is not a registered callable module” doesn’t tell us much about your error. Apparently, it is a downstream symptom in all React Native projects indicating “your app had some other error before it could finish loading.”

I’d recommend following the steps in this GH issue reply to try and find the error.

Hi charliecruzan,

I still could not trace the error, I tried running production mode on simulator it works fine but as i publish into apk it gave me the error shown. I also tried to search for the Symbol but could not make sense of it. What is the best way for me to debug it? I had Mobx decarator in the project, would that be a problem?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.