Missing Push Notification Entitlement with updated certificates

Hey there!

So I’ve tried to build my app for iOS. I let expo handle all that certificate stuff. I uploaded the build using the application loader. Everything is fine, except for a warning I received per mail:

Push Notification Entitlement - Your app appears to register with the Apple Push Notification service, but the app signature’s entitlements do not include the “aps-environment” entitlement. If your app uses the Apple Push Notification service, make sure your App ID is enabled for Push Notification in the Provisioning Portal, and resubmit after signing your app with a Distribution provisioning profile that includes the “aps-environment” entitlement. Xcode does not automatically copy the aps-environment entitlement from provisioning profiles at build time. This behavior is intentional. To use this entitlement, either enable Push Notifications in the project editor’s Capabilities pane, or manually add the entitlement to your entitlements file. For more information, see Local and Remote Notification Programming Guide: Configuring Remote Notification Support.

I went to developer.apple.com → Certificates, Identifiers & Profiles → APP IDs. My App ID had Push Notifications disabled. I enabled it (both Development and Distribution) and created and uploaded the keychain file.

Now the status of the Provisioning Profile under developer.apple.com → Certificates, Identifiers & Profiles → Provisioning Profiles went from “active” to “invalid”.

Push notifcations still don’t work in TestFlight. The android app is working fine, including push notifications. What am I missing here?

Also having this.

Having the same issue here. I notice that in Developer Portal " Certificates, Identifiers & Profiles" under “Keys” I have an entry for an “Expo Push Notification Key” created by Expo, but under my App ID it shows Push Notification “Disabled”.

Just want to point out that I went to https://developer.apple.com/account/ios/certificate/, deleted all iOS distribution certificates, all Provisioning Profiles, all Keys (push notifications), started fresh with expo using expo build:ios -c and … after uploading the new build with Application Loader, got the same email from Apple.

I have no idea what’s going on, nor how to fix it, nor how it can impact my users if I release this build in the wild (will it break push notifications?)

Tried using the new build with Test Flight and can confirm this 100% breaks push notifications :confounded:

having a similar issue and need to deliver a standalone app. I’ve gone in to detail in a separate post here: Push Notification Entitlement Missing in ios build


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.