Metro Bunder Connection LAN on macOS with firewall

When I run “npm start” in my Expo project I get the “Metro Bundler” browser window that displays a QR code. If I change “CONNECTION” to “Tunnel” can scan the QR code with my phone, the app loads fine in Expo Client. But if I leave “CONNECTION” on “LAN”, it only works if I disable the builtin macOS firewall. There must be a way to open port 19000 so “LAN” mode works with the firewall still enabled. Does anyone know how to do that?

Hey, my friend, I have fixed this issue enabling node script on the firewall and adding, click to add more applications on the firewall in your root user type command + shift + period (.), it’ll show the occult files, fined .expo folder and add Exponent…

It works for me