MapView not working on android

  1. SDK 41
  2. Android

Hi All,

I am using MapView with markers in my app and everything works smoothly when run on Expo Go.
When I switch to production:

  1. expo build:android
  2. upload generated build to Google Play Console within internal test

I see that the app run on my Android Smartphone crashes and restarts immediately when the MapView component should appear. Sentry shows nothing.
I entirely followed MapView guidelines from: MapView - Expo Documentation

I have two hyptohesis why the problem occurs:

  1. Maybe my SHA-1 key from Google Play console for the app is somehow bad?
  2. Because of the fact that the app has not been reviewed by Google Play yet, it name is changed to “package_name+(unreviewed)”, and maybe in Google API Console when I pass “package_name” value next to SHA-1 value, it does not correspond to the testing version app package name?

What are your opinions?
Is any of my hypothesis reasonable? What else could cause the problem?

Thanks in advance for your advise.

Problem Solved!

I’ve done two things at the same time:

  1. Update SHA-1 key on Play Console for my app
  2. Reinstall app on the device

I am pretty sure that step number 2 would be enough. I created another copy of app within Play Console and have done everything according to MapView guide and it worked once installed on my phone. Reinstallation seems to be the key.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.