MapView doesn't work

I’m was having a hard time making MapView to work, it only shows the google logo and a empty. Then I decided to view the MapView example on expo docs, and they show the same problem on android device.

I searched online, and already added :
"android": { "package": "", "config": { "googleMaps": { "apiKey": "myKey" } } }

to my app.json, but with no luck. Any one have a idea what’s going on?


I’ve build the project and installed on my phone and the maps worked, but still nothing on expo-cli


I am also having the same issue, @Expo is this an issue on your end?

1 Like

I’m having the same issue… Mapview won’t display tiles, just the Google logo in the bottom left corner. But the app with the map displays fine on my phone from expo. I’m running the emulator on Ubuntu 18.04.1 and qemu recently updated.

Same here.

Same error here, but if generating the APK and installing on the phone works.

Error occurs only at Expo


We’re really sorry for the inconvenience. Our team knows about this issue and is working right now to solve it.


I updated the app Expo ( Google Play ) and Maps again!
Thank you Team Expo!

Everything seems to work now. Thanks for the fast anwser

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.