MapView doesn't work in ExpoKit 33

MapView doesn’t work in ExpoKit.

It seems that react-native-maps doesn’t work with react-native 0.59.2.

Related issue:

When will be support for react-native 0.60 for expoKit?

Hey! Support for react-native 0.60 will be coming in a later SDK release (SDK 34 will be based on 0.59.8, like SDK 33 was)

What error are you seeing when trying to use MapView? Is it in Android or iOS?

@charliecruzan Instead of the map I see an error: " “App is having trouble with Google Play services. Please try again later”" , It’s Android.

@charliecruzan I use react-native-maps 0.24.2, I wanted to downgrade it to 23.0.0, but old version of react-native-maps throws a lot of build gradle errors.

In react-native-maps page it says, that it’s recommended to use react-native version 0.60.

If ExpoKit 33 doesn’t support maps, I will need to remove ExpoKit from the project completely.

I just tried on a brand new expokit project, and was able to generate a Mapview with no errors (expo bundles react-native-maps: "0.24.2" in with Expokit projects), so it looks like it does work, but there’s something different in your project causing the error.

Could you try it on a blank project and let me know if you run into the same issue?

Make sure you update your import syntax for Mapview to:

import MapView from 'react-native-maps';


I just have created new ExpoKit project, and I still see only empty map.

Any updates on this? I just ejected from expo (still using expokit) and the map would render properly in managed expo, but now just shows a blank screen. No obvious errors in logcat.

In case this helps future visitors, I found my issue:

For some reason, the Maps API key in my android manifest is not the one I specified in my app.json.

I’m not sure why they’d be different and I don’t know where the new one came from (appears to have been generated by expo when I ejected?) but doing a string replace of that with the correct one from my app.json resolved the issue for me.

I’m still facing issue.when i run command app getting crash(build successfully) but if i remove react-native-maps native code from android everything working fine except maps.