MapView doesn't show in Android App [Solved]

Hello everybody, as in the title the map doesn’t show in the Android build.

I followed all the steps in (section If you already have not configured Google Sign In) and honestly I don’t know what else I can do to make it work…
Any ideas? Thanks

Additional details:
I’m on a Windows 10 machine and while building I see the following error message in the Expo packager, but other than the map the app works fine.

[exp] fs.js:584
[exp] return, stringToFlags(flags), mode);
[exp] ^
[exp] Error: UNKNOWN: unknown error, open ‘C:\Users\leopa.babel.json’
[exp] at Object.fs.openSync (fs.js:584:18)
[exp] at Object.fs.writeFileSync (fs.js:1314:33)
[exp] at (D:\dev\RNative\pstores\node_modules\babel-register\lib\cache.js:48:16)
[exp] at emitOne (events.js:96:13)
[exp] at process.emit (events.js:191:7)
[exp] at process.exit (internal/process.js:162:15)
[exp] at process. (D:\dev\RNative\pstores\node_modules\worker-farm\lib\child\index.js:46:37)
[exp] at emitTwo (events.js:106:13)
[exp] at process.emit (events.js:194:7)
[exp] at process.nextTick (internal/child_process.js:766:12)

Solved, at least for now.
I tried over and over, the last time I created both a new project and new credentials on Same exact steps but this time worked!