Map API Key error on android after building via EAS

This was a little strange for me, so I decided to share it sounds like a bug.
The problem at hand is that when building with EAS and using the MapView module from expo, on Android it gives an error stating the API key is not set in the Manifest, however the weird part is that it works on the iOS, so I don’t know if this was intended or a bug.
But what I know is that there is no documentation telling you to add your api key for the android EAS build, or even how? (Probably same way as standalone I’d suppose?)

In your post, please share:

  • managed workflow SDK 44
  • Your eas-cli version : eas-cli/0.45.1 darwin-x64 node-v14.17.2
  • What you have tried so far : tried on iOS and it works fine, as this is really low level nothing else I could try on Android lol.

Hey @stevemoretz, for clarification, did you follow these steps for configuring Android? If not, that error is expected as you need to set your Google API key to be able to use Google Maps.

The reason iOS may be working is that it uses Apple Maps by default (which does not need additional configuration). Only when you want to use Google Maps on iOS do you need to add the Google API key.



Hello, thank you no I hadn’t followed that, because I thought that’s for when building at the end for production, so basically a Dev client is a stand-alone app, I didn’t know that!

And also thanks for explaining why it works on the iOS pretty cool!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.