macOS Catalina - zsh: command not found: expo

I have read every other thread on this topic and can not solve the problem yet.

In September 2019 I installed expo and have been developing smoothly. Recently I found I need to eject to use IAP.

Currently, when I try expo eject or any other expo command I get “command not found: expo”

I use yarn to start my node server, I can see that this runs expo start, but I am not able to run any expo commands.

  • I have checked my .bash_profile and do have the Global reference to node modules.

Any ideas?

Hey @gletorney,

Re-installing expo globally may help if you haven’t already tried it. Also, I would recommend taking a look at this SO Post:


Thanks, I have tried re-installing expo and I can’t get any expo commands to work. I saw Oh My Zsh but will need some time to dig in.

Is there a way to start fresh?? I’ve tried removing and re-installing expo using both npm and yarn - still not able to access any expo commands.

What caused this?

@adamjnav - thanks again for your advice. I followed the instruction in that SO post, to no avail.

Again, I am not able to access any commands on expo cli and have tried uninstalling and re-installing.

This is my first node project on this computer and have not installed other packages, only the expo environment so far.

Stuck until I can move this forward, any advice would help.

Looking at $PATH is probably the quickest way to debug this. You could try using something like Volta to install expo-cli in a pretty stable way. (You will need to add Volta’s bin directory to your $PATH. It will manage expo-cli and Node for you.)


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.