Local EAS build failing; SDK location not found.

My attempted local android Eas build is failing with the following error:

SDK location not found. Define location with an ANDROID_SDK_ROOT environment variable or by setting the sdk.dir path in your project's local properties file at '/private/var/folders/pf/vwkh48ps7qdbwz2xxn8mxp6r0000gn/T/eas-build-local-nodejs/bdb3d477-bffe-425b-9d4e-2f6e12f760ba/build/android/local.properties'.

I am using the managed workflow.

I tried editing that file to include
sdk.dir = /Users/USERNAME/Library/Android/sdk
from the SO solution.
I could not edit the file even with sudo.

I also tried looking in the expo documentation to see if I could specify the location of androiod studio with a variable, but didnt see an option there.

hi there! you need to have android sdk set up properly locally. Setting up the development environment · React Native – choose “React Native CLI” option and follow the setup instructions for your operating system for android

1 Like

Thanks so much. Got it working, however now it generates a .aab file, but the play store says invalid file type.