Loading expo in browser just searches

I’m having trouble running a basic generated app. I run with ‘expo start’ and I get the url and I try to go to that url in the browser (either with scanning the QR code or copy pasta) and neither way allows me to actually go the URL. It searches using me default search engine, google.

I understand this might be a stupid limitation of the browsers in question, but I find it hard to believe that nobody else has come across this issue.

I have tried using both Microsoft Edge Mobile and Chrome mobile. Should I be using a different browser? I’m on Android by the way.

Expo CLI 4.0.17 environment info:
OS: Linux 4.4 Ubuntu 18.04.3 LTS (Bionic Beaver)
Shell: 4.4.20 - /bin/bash
Node: 15.5.0 - ~/.nvm/versions/node/v15.5.0/bin/node
npm: 7.3.0 - ~/.nvm/versions/node/v15.5.0/bin/npm
expo: ~40.0.0 => 40.0.0
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
expo-cli: 4.0.17
Expo Workflow: managed

expo start by itself is for loading your app inside the Expo app on Android or iOS. If you want to view the react-native-web version of the app in a browser you should either start with expo start -w, or else press w after running expo start.

If you do that, the browser should open automatically and display your app.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.