Live Reload Not working? (iOS)


I’m trying to use Expo to develop a simple app. From what I understand, Live Reload lets me edit code and see the changes appear on the Expo app for iOS. However, I get this error if I either click “production mode” or if I make a change in the code and try to get it to appear on the app.

Error that shows up on my iPhone SE Expo App (Sorry for copy and paste, I can only upload one picture!):

Could not connect to development server.

Ensure the following:

  • Node server is running and available on the same network - run ‘npm start’ from react-native root
  • Node server URL is correctly set in AppDelegate
  • WiFi is enabled and connected to the same network as the Node Server

URL: [url here]



I’ve been googling for a couple of hours and I’ve tried:

  1. Running npm start instead of expo start
  2. Running cmd in adminstrator
  3. Disabling all of my A/V

My laptop and phone are definitely on the same wifi network.

Thank you for reading! If there’s any useful information that I omitted, please let me know.

Hey @eigengirl!

So live reload isn’t available when running in production mode, but I’m not sure why you’d get this error when making any changes in dev mode.

Have you tried clearing node_modules? Also what version of Expo CLI are you using? (run expo diagnostics and paste the output here :+1:

1 Like


Thank you for replying. What do you mean by clearing node_modules?

Expo CLI Version:

Hope this helps!

Delete the node_modules folder and then run yarn or npm i to install your dependencies again

That worked! It’s live reloading on my app now and I don’t get an error. Thank you so much! I appreciate it.

1 Like

Woo! That’s awesome to hear :slight_smile: