Live app async calls not working

Please provide the following:

  1. SDK Version: 37.0.0
  2. Platforms(Android/iOS/web/all): Android

Didn’t know which help category to put this in so I apologise if it is in the wrong one. I have just released my expo managed workflow app to the play store and downloaded it today. I have tried to log in (as the first screen is a log in screen) however the async call just times out eventually. I tried my version with expo start to see if I missed something before it was released, but the expo start version works fine and logs in almost instantly so I don’t understand what the problem could be.

Hey @sarcodo,

Can you elaborate on what you mean by “log in”? Are you using an auth provider or one of the Expo modules that enables authentication?


Hi Adam,

So the first screen of my app is a log in screen, this is simply done using the axios module to call an api on my server which will then determine whether the log in details are valid or not. It isn’t using any Expo module for this. However this does work when I’m running it on my laptop using the expo start command and testing on my phone with the expo app, but after I’ve run the expo build command and built an android bundle file which was uploaded to the play store and then tested on my phone the ‘log in’ request times out. There is also a ‘sign up’ function which again works with the expo start command but not with the downloaded app from google play, which just times out.


The old answer for synchronize these calls was by means of settled callbacks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.