Latest SDK 42 doesnt work with latest expo go client app

Please provide the following:

  1. SDK Version 42
  2. Applies to all
  3. expo cli

So i have done a complete fresh install of Node, NPM, expo-cli Android Studio and XCode, so everything as of today is runnning on the latest version.

I use the expo-cli to create an application expo init. It creates the app and installs dependancies just fine, i am able to see the expo browser user interface and also the “run in web browser” option version of my app works.

When it comes to the android and IOS simulators both throw exactly the same error; (i am using SDK v42)

Invalid sdkVersion. Valid options are 7.0.0, 8.0.0, 9.0.0, 10.0.0, 11.0.0, 12.0.0, 13.0.0, 14.0.0, 15.0.0, 16.0.0, 17.0.0, 18.0.0, 19.0.0, 20.0.0, 21.0.0, 22.0.0, 23.0.0, 24.0.0, 25.0.0, 26.0.0, 27.0.0, 28.0.0, 29.0.0, 30.0.0, 31.0.0, 32.0.0, 33.0.0, 34.0.0, 35.0.0, 36.0.0

expo-cli is installing the expo go client app on the devices for me but doesnt seem to be installing the latest version. On both xcode simulator and android studio i have completely wiped devices and tried again but still no luck. I have removed and installed the latest version of expo Go from the google play store on the android device (cant do this on IOS simulator because it doesn’t have the app store) but still getting the same error.

Here is my package.json; (the default one that the expo init command creates)

{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject"
  },
  "dependencies": {
    "expo": "~42.0.1",
    "expo-status-bar": "~1.0.4",
    "react": "16.13.1",
    "react-dom": "16.13.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-42.0.0.tar.gz",
    "react-native-web": "~0.13.12"
  },
  "devDependencies": {
    "@babel/core": "^7.9.0"
  },
  "private": true
}

and app.json;

{
  "expo": {
    "name": "app",
    "slug": "app",
    "version": "1.0.0",
    "orientation": "portrait",
    "icon": "./assets/icon.png",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    },
    "updates": {
      "fallbackToCacheTimeout": 0
    },
    "assetBundlePatterns": [
      "**/*"
    ],
    "ios": {
      "supportsTablet": true
    },
    "android": {
      "adaptiveIcon": {
        "foregroundImage": "./assets/adaptive-icon.png",
        "backgroundColor": "#FFFFFF"
      }
    },
    "web": {
      "favicon": "./assets/favicon.png"
    }
  }
}

Iv been at this for days, iv tried every solution i can find on the internet, cleaning caches, completely wiping the virtual devices, etc but still no luck. Any help would be appreciated thanks.

what version of expo-cli do you have? Check by running expo-cli --version, it’s possible that you updated version installed via npm, but you are using version installed via yarn

Thank you for taking the time to help!

My expo-cli version is 4.12.1

also - im using npm to install packages and not yarn

A few other details to help if relevent;

expo-cli version: 4.12.1
OS: MacOS Catalina Version 10.15.7
Node Version: 16.1.0 (served through NVM if thats relevant)
NPM Version: 7.24.2
Android Studio Version: Arctic Fox 2020.3.1 Patch 2
XCode version: 12.4

further updates, i tried a fresh install on my personal Lenovo laptop with Ubuntu 18 installed and everything worked seamlessly. Could this be a MAC related issue?
I did notice that the android emulated device cannot reach the internet, i tried all sorts of DNS settings to try and fix this button no luck. could this also be a factor? if google play store cant reach the internet it cant download the most updated version of expo client app? but then how does it download any version of it in the first place?

So i seem to have solved my own issue. I dont know exactly how i did it nor how i got into this state but there seemed to be a mismatch of expo versions installed. I am using NVM to manage node versions and using the which command (which expo) managed to see that the executable for expo being used was the one inside the NVM node version folder instead of the one in the global /bin folder. I deleted all instances on the system of expo and expo-cli and reinstalled and it seems to have worked.

1 Like