Keystore file not found for signing config 'release'

Decided to test build via EAS for our app.
Made all instructions from “Creating your first build”
And now when i run build locally via eas build --platform android it fails on last step with error

Execution failed for task ':app:validateSigningRelease'.
> Keystore file '/build/workingdir/build/android/app/my-upload-key.keystore' not found for signing config 'release'.

Additional info:

  • all credentials was generated by expo
  • when we ejected from managed to bare workflow i builded app for hundreds of times with credentials stored in expo
  • now when i build locally no problems with keystore. But there was strange thing after trying to build via EAS for the first time my keystore passwords in Android Studio messed and were wrong(were much more longer when was before), so i downloaded credentials from expo(via site) kept original keystore but replaced passwords on passwords provided by expo from and now all works again, not sure that its related to EAS build, but there was no unusual actions that i can did in last days that might broke touch android studio
  • dont have credentials.json
  • expo account name is “winstrike”
  • credentials copied to EAS are the same

expo diagnostics

Expo CLI 4.7.2 environment info:
      OS: Windows 10 10.0.19042
      Node: 14.15.1 - C:\Program Files\nodejs\node.EXE
      npm: 6.14.8 - C:\Program Files\nodejs\npm.CMD
      Android Studio: Version AI-202.7660.26.42.7351085
      expo: ^41.0.0 => 41.0.1
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: 0.63.4 => 0.63.4
    Expo Workflow: bare

We use this file expo-cli/EasBuildGradleScript.ts at master · expo/expo-cli · GitHub , to override signing config.

Check there System.getenv("EAS_BUILD") != "true" is incorrect and as a result we do not override your existing config, which you can see form logs

Path to release keystore file is already set, ignoring 'credentials.json'

line 46 in your last build

credentials.json refers to file to that is created on worker, even if you are using managed credentials credenitals.json will be created.

We will need to fix that on our side, but as a temporary workaround you can either

  • remove release config from your buidl.gradle
  • override env EAS_BUILD=true in eas.json
1 Like

Thanks a lot. Made workaround recommendations now it works :sunglasses:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.