just install SDK 35.0.0 and got some errrors

Hi,
I just installed SDK 35.0.0 and after following all instructions I am getting the following:
– Once I run expo start, I type i to start iphone simulator but the system hangs at this line:
Trying to open the project in iOS simulator…
Downloading the latest version of Expo client app
Installing Expo client on iOS simulator
/

on my iphone device, on the other hand, when I run my app, I see the following error:

Unable to resolve module @react-native-community/netinfo from /Users/aimnblbol/dev/oolfa/oolfa-mobile/oolfa/node_modules/@redux-offline/redux-offline/lib/defaults/detectNetwork.native.js: Module @react-native-community/netinfo does not exist in the Haste module map

Here is a list of all my dependencies in package.json:

“dependencies”: {
@apollo/react-hooks”: “^3.0.1”,
@expo/react-native-action-sheet”: “^3.0.3”,
“aws-amplify”: “^1.1.36”,
“aws-amplify-react-native”: “^2.1.16”,
“aws-appsync”: “^2.0.0”,
“aws-appsync-react”: “^2.0.0”,
“expo”: “^35.0.0”,
“expo-asset”: “^7.0.0”,
“expo-file-system”: “^7.0.0”,
“expo-image-picker”: “^7.0.0”,
“expo-intent-launcher”: “^7.0.0”,
“expo-localization”: “^7.0.0”,
“expo-location”: “^7.0.0”,
“expo-permissions”: “^7.0.0”,
“graphql-tag”: “^2.10.1”,
“hash-sum”: “^2.0.0”,
“moment”: “^2.24.0”,
“prop-types”: “^15.7.2”,
“react”: “16.8.3”,
“react-apollo”: “^3.0.1”,
“react-dom”: “^16.8.6”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz”,
“react-native-animatable”: “^1.3.2”,
“react-native-gesture-handler”: “~1.3.0”,
“react-native-paper”: “^2.16.0”,
“react-native-reanimated”: “^1.2.0”,
“react-native-web”: “^0.11.4”,
“react-navigation”: “^4.0.6”,
“react-navigation-fluid-transitions”: “^0.3.2”,
“react-navigation-hooks”: “^1.0.1”,
“react-navigation-material-bottom-tabs”: “^2.1.1”
},
“devDependencies”: {
“babel-preset-expo”: “^6.0.0”,
“eslint”: “^6.1.0”,
“eslint-config-airbnb”: “^18.0.1”,
“eslint-plugin-import”: “^2.18.2”,
“eslint-plugin-jsx-a11y”: “^6.2.3”,
“eslint-plugin-react”: “^7.14.3”,
“eslint-plugin-react-hooks”: “^2.0.1”
},

Apparently you now need to run:

expo install @react-native-community/netinfo

https://docs.expo.io/versions/latest/sdk/netinfo/#installation

yup, that resolved the issue on my devices but I am still not able to run my app on the iphone simulator.
But there is one interesting point, why do I have to install @react-native-community/netinfo if I am not using it? Shouldn’t the library using it, does that??
Any way, please help with the simulator part.
Thanks

I’m afraid I don’t know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.