Issues with Expo detached build

I had to detach application form expo in-order to implement onesignal and background processes which was quite intimidating. I am having hard time building apk and running in different devices at the moment.

I ran exp start in command line and run application in emulator which worked.
Then I installed debug apk in some devices and try to run I will get following error .
Packager not running at
Then I stop and start exp project again and installed app in mobile works now but emulator start to show same error again.

Can some one please guide me through the process of building apk which will work easily in testing devices without needing to start project in terminal again and again. What will be the appropriate way to send test app to client and deployment following with Expokit starndards?

much appreciate your feedback,

Hi @surajmaharjan! Urls that look like will only work if your phone and computer are on the same wifi network. You can try running exp start with the --tunnel flag so that it’s not as dependent on your local network configuration. Make sure that you run exp start --tunnel before building the Android project.

Hi @jesse, thanks for the response. I certainly figure out that but my problem was it stops listening once I switch between emulator and device. I end up with blue scree again with message for that I need to stop and start exp start.

Can you explain exactly what steps you are doing?

Sometime uninstall application and running again works but it’s quite frustrating experience to go through all to just run and test application.


I’m sorry it’s frustrating, but I still don’t know exactly what steps you are taking.

1 Like

No worries @jesse. Sometimes it quite frustrating but mostly it works now. Thanks for your support.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.