Issue uploading .IPA app to Apple Store (Application Loader)

Hi, i’m facing a issue to upload a .IPA to Apple Store and I don’t know what happens.

The error is:

ERROR ITMS-90163: “Invalid Code Signing Entitlements. The entitlements in your app bundle signature do not match the ones that are contained in the provisioning profile. The bundle contains a key that is not included in the provisioning profile: ‘’ in ‘Payload/’.”

The same error is reported previously on Uploading to Application Loader Failed,
but the solution proposed don’t work for me.

I did the same tries to solve, but not has been worked.

Distribution certificate is ok
Push Certificate is ok
Provisioning profile is ok

Please, someone can help me?

My enviroment info:

  Expo CLI 2.6.10 environment info:
      OS: Linux 4.15 Ubuntu 18.04.1 LTS (Bionic Beaver)
      Shell: 4.4.19 - /bin/bash
      Node: 8.10.0 - /usr/bin/node
      Yarn: 1.12.1 - /usr/local/bin/yarn
      npm: 6.4.1 - /usr/local/bin/npm
      expo: 30.0.1 => 30.0.1 
      react: 16.3.1 => 16.3.1 
      react-native: => 0.55.4 
      react-navigation: 3.0.4 => 3.0.4 
      expo-cli: 2.2.6

My problematic build:

Thanks and happy hollidays. Cheers!


Are you using usesICloudStorage in app.json?

Have you tried revoking your certificates on and generating new ones with expo build:ios -c?

No, I’m not using this feature. ;/

Yes, couple times. My last try was use my own Distribution certificate, and let expo generate Push Certificate and Provisioning profile.

As follow:

expo build:ios --release-channel prod -c --revoke-apple-dist-certs --revoke-apple-push-certs

You tried also with distribution certificate generated by expo-cli?

Do you have any other distribution certificate on your Apple account?

Yes, many times.

No, i have only one Distribution certificate.

Try upgrading expo-cli package (npm install -g expo-cli), revoke certificates and run expo build:ios -c again

Hi Jak, I did the update of expo-cli, but i still stucked with the error. ;/

The new failing build is:

Any other tips? Thanks!!

Could you paste your app.json file content?
I checked your manifest and it has the key "usesIcloudStorage": true

I figure it yesterday, I did a double check on app.json after you said, but at first view, I m was so blind and can not see this property… Please, sorry.
I started a new build without usesIcloudStorage yesterday yet, and today I’m trying to upload…
I will reply here when I got the result.
By now, thanks a lot!

Hi, the upload process has been completed sucessfully.

The problem was “usesIcloudStorage: true”, without this prop, the issue is gone.

But, I had one question: How are the right way of using “usesIcloudStorage”: true? If I need to include him back to my app.json, how to do?


Hey @infosolo,

If you need to enable iCloudStorage, you can follow this guide:



This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.