Issue opening iOS simulator: 'Unable to determine runtime bundle when booting device.'

EDIT: all my simulators disappeared for seemingly no reason, restarting fixed it somehow. thread can be found here

Tried to run simulator this morning (no changes from yesterday) and it prompted me to install tools provided by apple. After doing that, I’m receiving this error message in the cli:

Error running `xcrun simctl boot B67C8C06-53EB-4CE9-8E56-C537CACDCCFD`: 2019-07-23 11:21:44.638 simctl[11177:185690] *** Assertion failure in -[SimDevice _onBootstrapQueue_bootWithOptions:error:](), /Library/Caches/
2019-07-23 11:21:44.639 simctl[11177:185690] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Unable to determine runtime bundle when booting device.'
*** First throw call stack:
	0   CoreFoundation                      0x00007fff4be2fcfd __exceptionPreprocess + 256
	1   libobjc.A.dylib                     0x00007fff764d9a17 objc_exception_throw + 48
	2   CoreFoundation                      0x00007fff4be4aa1a +[NSException raise:format:arguments:] + 98
	3   Foundation                          0x00007fff4e1381e5 -[NSAssertionHandler handleFailureInFunction:file:lineNumber:description:] + 166
	4   CoreSimulator                       0x000000010d7c5745 -[SimDevice _onBootstrapQueue_bootWithOptions:error:] + 2085
	5   CoreSimulator                       0x000000010d7c4f00 __35-[SimDevice bootWithOptions:error:]_block_invoke + 60
	6   CoreSimulator                       0x000000010d7dcd49 __32-[SimDevice bootstrapQueueSync:]_block_invoke + 16
	7   libdispatch.dylib                   0x00007fff77c5a63d _dispatch_client_callout + 8
	8   libdispatch.dylib                   0x00007fff77c66129 _dispatch_lane_barrier_sync_invoke_and_complete + 60
	9   CoreSimulator                       0x000000010d7dccdc -[SimDevice bootstrapQueueSync:] + 169
	10  CoreSimulator                       0x000000010d7c4d4a -[SimDevice bootWithOptions:error:] + 190
	11  simctl                              0x000000010d740fbe simctl + 126910
	12  simctl                              0x000000010d74b434 simctl + 169012
	13  libdispatch.dylib                   0x00007fff77c595f8 _dispatch_call_block_and_release + 12
	14  libdispatch.dylib                   0x00007fff77c5a63d _dispatch_client_callout + 8
	15  libdispatch.dylib                   0x00007fff77c68509 _dispatch_root_queue_drain + 657
	16  libdispatch.dylib                   0x00007fff77c68b46 _dispatch_worker_thread2 + 90
	17  libsystem_pthread.dylib             0x00007fff77e9a6b3 _pthread_wqthread + 583
	18  libsystem_pthread.dylib             0x00007fff77e9a3fd start_wqthread + 13
libc++abi.dylib: terminating with uncaught exception of type NSException

There was a problem booting a device in iOS Simulator. Quit Simulator, and try again.
Error installing or running app. Error: xcrun exited with signal: SIGABRT
1 Like

Thanks for linking the thread/solution @metoo! Definitely a weird error, can’t say I’ve seen it before

I’m having the same issue, randomly after being asked to install some xcode related tools

Hey @biarrioptimisation,

Wait for the install to be complete and then try running expo start --ios again. If you run into an error, multiple reports on the thread Derek linked to mention that restarting your Macbook should suffice. If not, another user in said thread mentioned having to uninstall Xcode, clear the archive in the Library directory and then re-install.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.