Issue launching Expo app on new device

I have an expo app that is causing issues on some phones when launching. Haven’t had this issue with the same phone before but haven’t opened it on said phone for over a month.

Initially I had 3 test devices and 2 of them were in use everyday, third was only used once to open and test small functionality and then recently (causing this issue). Weird thing is, I don’t have any screens that have these three buttons like this.

Expo SDK: 30

iPhone 5c – Works |
Samsung S6 – Works |
Google Pixel – Doesn’t Work |
Samsung S7 Edge – Doesn’t Work

Things Tried:

Build and Download APK (unknown sources) – Same Result |
Publish to Expo and Open with app (under profile) – Same Result |
Connect via CLI (Tunnel & same Network) – Same Result

** all of these with the exception of APK worked on these devices prior (few weeks)

Ok guys & gals, I found the issue

Basically, I had a SwitchNavigator and for w.e reason the app was loading that particular page. For those who have this issue, if you have a device that has this app and you make changes, check the routing to the switch navigator and ensure it doesn’t render this first.

For me it was part of the auth flow so it was rendering first but there was some logic that made this particular screen inaccessible for the devices.

This weird edge cases threw no errors or anything, and this route on the switchNavigator should not have even loaded as there was logic to re-route, but here we are :slight_smile:

Solution 1: make the switch nav a stack or tab
Solution 2: check validation and add logic to pass switch if not needed
Solution 3: remove routing to this page

That’s interesting. Thanks for sharing the solution with the community.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.