iOS - Standalone build failed!

Hi there,

I am failing with ios standalone builds, here some details:

exp: 53.1.0
sdk: 24.0.0

ios build failed, I don’t get any error that I can work with, would you take a look and assist here?
tried with EXPO_DEBUG=true, still nothing :frowning:

11:40:27 [exp] Making sure project is set up correctly...
11:40:38 [exp] Your project looks good!
11:40:39 [exp] Checking if current build exists...

11:40:39 [exp] No currently active or previous builds for this project.
11:40:39 [exp] If you get errors about

'Maximum number of certificates generated' or 'duplicate profiles'

then consider using the flags --revoke-apple-dist-certs, --revoke-apple-push-certs,
and --revoke-apple-provisioning-profile or go to developer.apple.com
and revoke those credentials manually

11:40:40 [exp] Using existing credentials for this build
11:40:40 [exp] Unable to find an existing exp instance for this directory, starting a new one...
11:40:51 [exp] Starting Metro Bundler on port 19001.
11:40:52 [exp] Metro Bundler ready.
11:40:54 [exp] Tunnel connected.
11:40:55 [exp] Publishing to channel 'default'...
11:41:04 [exp] Building iOS bundle
11:41:26 [exp] Finished building JavaScript bundle in 21954ms.
11:41:26 [exp] Building Android bundle
11:41:46 [exp] Finished building JavaScript bundle in 20524ms.
11:41:46 [exp] Analyzing assets
11:42:08 [exp] Finished building JavaScript bundle in 21604ms.
11:42:29 [exp] Finished building JavaScript bundle in 21618ms.
11:42:30 [exp] Uploading assets
11:42:32 [exp] No assets changed, skipped.
11:42:32 [exp] Uploading JavaScript bundles
11:42:36 [exp] Published
11:42:36 [exp] Your URL is

https://exp.host/@assafyardeni/treatoNow

11:42:37 [exp] Building...
11:42:37 [exp] Build started, it may take a few minutes to complete.
11:42:37 [exp] You can monitor the build at

 https://expo.io/builds/cd3ad885-d03f-4410-83b8-bfd4f11fca80

|11:42:37 [exp] Waiting for build to complete. You can press Ctrl+C to exit.
/11:43:38 [exp] Standalone build failed!
building and signing IPA
Executing command: security cms -D -i /private/tmp/turtle/7e18cb31-6294-4f3f-b184-8b5faf93daad/provisioning/7e18cb31-6294-4f3f-b184-8b5faf93daad.mobileprovision
done retrieving provisioning profile
Checking if teamID is present in keychain and that certificate is valid...
decoding p12 certificate
verifying certificate is installed
Executing command: security find-identity -v -s (XXXXXXXXXX)
confirmed team ID is present in keychain
Chose export method: app-store
writing export-options.plist file...
building IPA
Executing command: fastlane gym -n unsigned.ipa --workspace /usr/local/turtle-agent/shellAppWorkspaces/ios/default/ExpoKitApp.xcworkspace --scheme ExpoKitApp --archive_path /private/tmp/turtle/7e18cb31-6294-4f3f-b184-8b5faf93daad/archive.xcarchive --skip_build_archive true -i 986175EBF5CDF4E1509FA8C39A46C4E5AB4166F3 --export_options /private/tmp/turtle/7e18cb31-6294-4f3f-b184-8b5faf93daad/provisioning/export-options.plist --export_method app-store --export_xcargs OTHER_CODE_SIGN_FLAGS="--keychain /private/tmp/turtle-agent/46bd8548-4eac-11e8-8b99-0050568e7f20.keychain" -o /private/tmp/turtle/7e18cb31-6294-4f3f-b184-8b5faf93daad/build --verbose
Unable to generate IPA.
unable to build and sign IPA

hi @oren, that’s really weird – usually the actual error should be surfaced. I’ve dug through these logs on our end, and I’ll email you the details of the errors we are seeing.

Sure, many thanks, looking forward for your email.

Just saw it, thanks.

Well, thanks for your help, I confirm that it was something related to the certificates, for some reason it failed with the certs stored on exp account.

Glad you got it resolved!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.