iOS standalone app in Testflight not able to get push token

After following the latest push notification example here, I build my ios app on, let expo handle all of my certs (including push notification api key instead of p12 cert), and then deploy to the app store and install on my phone through testflight.

While testing my app from the expo app, I successfully get the expo push token and can send notifications to my phone. When testing the exact same code on the stand alone app through Testflight the status returns undetermined and the push token is undefined

I created a new expo project from scratch and get the same result. I also tried to downgrade expo sdk to v31, but then getExpoPushTokenAsync() just throws an error.

I’m pretty certain that my code is not the issue now, but haven’t seen many others having this issue on the forums or github issues. Is this a known issue that’s being worked on?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.