iOS Simulator Not Launching from XDE


When trying to launch the iOS simulator from XDE, I get the following error:

Error installing or running app. Error: Command failed: osascript -e tell app “System Events” to count processes whose name is “Simulator”
28:69: execution error: System Events got an error: Application isn’t running. (-600)

I also tried launching the simulator first and then clicking it from XDE, but I get the same error.

I’m not sure what suddenly caused it to stop working. The simulator has worked in the past.
Any ideas how to get it running again?

I am using:
macOS High Sierra 10.13.4
Expo XDE Version 2.24.4 (
XCode Version 9.3 (9E145)
Simulator Version 10.0 (SimulatorApp-851.2 CoreSimulator-518.19)

Have you tried the “Erase all content and settings…” button located in the “Hardware” tab?

I just tried it, and that + a restart fixed it. Thanks Evan!

1 Like

Happy to help, what did you restart exactly? (Just for future reference) :grin:

:smile: I had to restart my whole computer actually.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.