IOS Notification problem (it's working on Android)

Hello,

I’ve build an application with Expo 41.0.1 with eas-cli 0.38.3.

The problem is about notifications. I’ve read all the available documentations and the notifications are working fine on Android phone but not on my iPhone.

I’m using eas to build for both platform.

Here is the error message :

{“data”:{“status”:“error”,“message”:"“ExponentPushToken[xxxxxxxxx]” is not a registered push notification recipient",“details”:{“error”:“DeviceNotRegistered”}}}

What I’ve tried :

  • reset the key and ensure they are delete (and then recreate) in my developer account

  • I’ve checked here (Sign In - Apple) that an identifier exist and that the notification is checked. Please note that there are no certificate however. Don’t know if eas is supposed to create some.

  • uninstall & reinstall the application

  • uninstall & reinstall TestFlight (AND the application again)

  • Found a similar issue on the forum but no answer is given => Please Help! ios notification problem.

I’m sure the token is generated because I display it in an alert box.

Is there any way to force the regeneration of the token in Apple ? Even when i uninstall/reinstall multiple time the application, I still get the same token value.

Please, could someone help

Thanks