ios build, where is the ipa?

I’m a little confused.

I run expo build:ios. It finally gives me a link to ipa file.
I download the file and it has a zip extension. I do not see a file in the zip with an ipa extension. I look on the web and it says ipa can be opened with unzip so I figured the whole zip file is the ipa. I put it on my mac, use application loader, select “deliver your app” to open it and it shows me my app info. I click next and then get error message: The operation couldn’t be completed: is a directory.

What am I doing wrong?

Hey @dwillis,

It should just a single IPA file that gets unzipped after you have downloaded it. Can you let me know what version you are running of the expo cli? Also, have you tried another build to see if that works? Thinking there may have been some transient error.



I rebuilt the app and downloaded it directly to my Mac. The extension now has ipa and I can upload it to the App store. Previously I downloaded it to Win 10 and uploaded it to google drive and then downloaded it to the mac. When I downloaded it to Win 10 it had a zip extension.

Thank you for your help!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.