iOS build stuck in que


My ios build has now been stuck in que for an hour or so, and I have tried to cancel and restart 4-5 times over the last 12 hours or so.

Is there anything that I should be aware of or keep in mind? Any downtime on the servers or unexpected longer waiting times?

Build ID: 5e8bc300-ae88-4947-8145-1ae00bf62400


All builders are working fine. In fact we don’t see your build ID in our logs at all. Could you show us the output from exp build command?

Also: which version of exp and SKD are you using?

SDK 29.0.0
Exp 57.0.0

For the record: The issue was assets number. We’ll do something to increase it.

1 Like

Having a similar issue. Ran a build earlier and it was queued for about an hour. Cancelled it and running again, this build has been queued for about 10 minutes. Android ran fine, iOS failed before and is queued currently.

Build ID: [id]

Edit: scratch that, it just completed successfully.

So this has now been solved with help from Expo, I had a npm package with flags that inported not only the ones I used but all 2500 of them. That prevented me from building only on iOS but not Android. This lack of error message is now on the Expo’s radar and will hopefully be dealt with in the future!

Thanks for good feedback and fast response Expo team!

@jhorner you probably just experience long queue that occurred yesterday :wink:

@thorarinn happy to help you :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.