Ios Build on queue for a long time


i am facing the following issue for a long time now:
[exp] iOS: Build waiting in queue…
Build ID: 63e6fcca-80a6-4dd9-82b1-ced4e41e81fb

But is already in the queue for more than 1 hour.
Please help, i already tried a lot of solutions if founded in this forum.



Hi @ganhomais - Standalone app builds for iOS are currently paused. We’re sorry about this unexpected issue. You can subscribe to this incident here and we’ll notify you when you can try submitting your build again:

I hope you find out soon the problem. thank you!

I guess it could be stuck again, my build is there for a long while 799dd650-3cad-457c-9012-2332fce487d8
Thank you for checking out

1 Like


I am also experiencing problems while building for iOS. Has been stuck in the queue for several hours so far.

My build is fbc036a1-39f4-4120-914a-7ba5ab3f0261



same here, build is queued for 4 hours now and while queued I can not cancel and resubmit it. Is there still an issue on your side?

Build ID is 959530d3-2e06-49d9-bbbb-6866ad0e8295.


Same problem for me as well, my iOS build has been queued for 3 hours now.

My build ID is 56234d1d-0d02-491e-9bc9-fb49037c96ee.

Same here, queued for 3 hours: 96923ea0-cf3e-43cd-bc0c-8a9d067ecd6c

Feature request:

How about adding a chart with the number of builds queued or average waiting time over the last 24h at with live data? So everyone could see: “Oh, it’s going up. They have an issue. I can fetch a coffee ;-)”

Statuspage is offering a system metrics feature (



Same here, iOS build on queue for about 2 hours now.
Build id: 89836880-991b-4e95-9ab7-8a316643285f


same problem on iOS build - queue for 6 hours;/
build: a7286a8f-0374-480b-84c7-d68262837577

Now it was finished, but with the error message in the log:

<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>AccessDenied</Code><Message>Access Denied</Message><RequestId>ABAC5C277E6C5206</RequestId><HostId>EPZ6bPJJrZQe9C0GyXGSEYI3G38to1ZeMjwnHt4BKx8sAvTqkQgjNx1dFBCc7N9SH522dKewixU=</HostId></Error>

Is this my own problem or is this a platform issue?

hi there! we are fixing an issue with the ios build service, it’ll be back up shortly, sorry for the hassle


Thanks! The archive build is working again.

The simulator build is still hanging for me:

running simulator build
extracting build configuration from app.json

…and it doesn’t do anything after that. Current build id: 0f7bd55b-541a-457b-a343-977b7815f5b8


  "expo": {
    "name": "YetPet",
    "description": "O novo jeito de cuidar",
    "slug": "yetpet-owners",
    "privacy": "unlisted",
    "sdkVersion": "25.0.0",
    "platforms": ["ios", "android"],
    "version": "1.0.1",
    "orientation": "portrait",
    "icon": "./assets/images/icon.png",
    "notification": {
      "icon": "./assets/images/notification-status-bar.png",
      "color": "#02ABDC",
    "splash": {
      "image": "./assets/images/splash.png",
      "backgroundColor": "#02ABDC",
    "assetBundlePatterns": [
    "ios": {
      "supportsTablet": true,
      "bundleIdentifier": "",
      "buildNumber": "1.0.1",
      "loadJSInBackgroundExperimental": true,
      "splash": {
        "image": "./assets/images/splash.png",
        "backgroundColor": "#02ABDC",
        "resizeMode": "cover",
    "android": {
      "package": "",
      "icon": "./assets/images/android-icon.png",
      "versionCode": 3,
      "splash": {
        "image": "./assets/images/splash.png",
        "backgroundColor": "#02ABDC",
        "resizeMode": "cover",
        "ldpi": "./assets/images/splash.png",
        "mdpi": "./assets/images/splash.png",
        "hdpi": "./assets/images/splash.png",
        "xhdpi": "./assets/images/splash.png",
        "xxhdpi": "./assets/images/splash.png",
        "xxxhdpi": "./assets/images/splash.png",

Hi @fvfelipe I didn’t see a buildJob thats in progress for the build id that you posted, could you try again and let me know if you’re still running into the same issues?

1 Like

thanks @jimmylee, I’ve started a new one and it seems stuck the same way:

exp build:ios -t simulator --release-channel production-v1 --no-publish
(no-publish because I’ve just published a version to build the .ipa and it worked)

1 Like

At the moment I am not sure what is causing your build to stall in that way (First time I’ve seen this). So I have escalated this issue to people who are more experienced in this domain.

I’m really sorry about the inconvenience! We will figure this out @fvfelipe

1 Like

Hi @jimmylee, I’m also getting this issue with, where my build seems hung after

running simulator build
extracting build configuration from app.json

Please let me know if there’s any additional info I can provide :slight_smile:

EDIT: FYI I just cancelled the aforelinked build so that I can start a non-simulator build.


My build seems to be stuck too,

Can you cancel it? Or if I have a way of doing it, I’d of course like to do it myself and learn how :slight_smile:

Mine too!

how can i cancel it? Thanx :slight_smile: