Ios build is not accepted by testFlight

I made a build with expo build:ios this morning and got a error when I upload my ipa to testFlight,
ERROR ITMS-90725: “SDK Version Issue. This app was built with the iOS SDK. All iOS apps submitted to the App Store must be built with the iOS 11 SDK or later, included in Xcode 9 or later. Further, starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later.”
and I am using sdk 31.
“sdkVersion”: “31.0.0”

Hey @yuhaoli,

The SDK 31 you’re referencing is Expo’s SDK. This seems to be referring to the iOS SDK.

Looks like you need to update your version of Xcode.

Good luck!

Hey @yuhaoli,

Can you ensure that you are running the latest version of the expo-cli? Our builders for SDK31 have been updated and are built with iOS SDK 12.1+.

If that’s not the the case, there may have been a regression pushed out to prod. I haven’t seen other reports of this however.

Let me know!


Sorry for the late reply, I updated my xcode yesterday, and get accepted by testflight after rebuilt the ipa. Thanks for the help

I run into the same problem. And just want to confirm, I found out that you have to have the latest versions on macOS, xcode and expo to bundle your app in order to be accepted for testflight/ app store.
After that no problems.

1 Like


I am having this problem. I just built with Expo SDK 32 and also have XCode 10.1 Stable release and running on MacOS 10.14.3 Beta. I able to submit fine till last week. But just today I am trying to submit and its throwing this same error. Any help will be greatly appreciated. Been stuck on this problem.

Ok well the issue is resolved now. Maybe I was really low on disk space or something. Don’t know. But i cleaned up my Mac and its working now! Thank you

Happy to hear that it’s working for you now, @idrlmartian.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.