iOS build gets "Missing Info.plist key" when using Amplitude

I’m using vanilla Expo (without detach). And it’s an amazing product, by the way. Great job guys.

I tried to publish a new version of my app, this time with Amplitude included.
And I received an email from Apple:
"We identified one or more issues with a recent delivery for your app, “HotelForce”. Please correct the following issues, then upload again.

Missing Info.plist key - This app attempts to access privacy-sensitive data without a usage description. The app’s Info.plist must contain an NSLocationAlwaysUsageDescription key with a string value explaining to the user how the app uses this data."

I kind of suspected that the reason could be Amplitude, so I removed it from my code and send the build to Apple again.
And this time it worked fine.

Looks like Amplitude is using user location? Why?
I’m not requesting user location permission in my app and I don’t want to.
What do I do?

Hi @n0_quarter – really sorry for the inconvenience here. Nothing to do with Amplitude, actually. It appears that Apple has changed their code review process in the past few days, such that any app built with Expo or even vanilla React Native is triggering this guideline.

We believe we have a fix but we’ve been unable to test and deploy it because TestFlight has been down :disappointed: you can track the status of this issue here: We’re hoping to deploy the fix sometime today, after which you’ll need to run exp build:ios again and re-submit your binary to Apple.

Again, really sorry for the trouble. Please let us know if you have any other questions about this.

Understood, thank for the update!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.