ios build fails with authentication error

i am getting error when i am running expo build:ios
i have used it number of times before with no issues. here is the error i am getting:
Reason: Unknown reason, raw: “Unauthorized Access”
Error: Reason: Unknown reason, raw: “Unauthorized Access”
at runAction (/usr/local/lib/node_modules/expo-cli/src/appleApi/fastlane.ts:28:17)

i have tried with developer account holder as well as a developer account and both are giving the same error.
here is the diagnostic information

Expo CLI 3.22.3 environment info:
OS: macOS 10.15.6
Shell: 3.2.57 - /bin/bash
Node: 12.16.2 - /usr/local/bin/node
Yarn: 1.22.4 - /usr/local/bin/yarn
npm: 6.14.4 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Xcode: 11.6/11E708 - /usr/bin/xcodebuild
expo: ^37.0.12 => 37.0.12
react: ~16.9.0 => 16.9.0
react-dom: ~16.9.0 => 16.9.0
react-native: => 0.61.4
react-native-web: ~0.11.7 => 0.11.7
expo-cli: 3.22.3

i upgraded to latest expo cli and still the same error :frowning:

Do you have the “owner” specified in app.json? Is this the same user that you logged in with using expo login?

I’m having exactly the same issue. I was able to run expo build:ios yesterday with no issues.

I was able to resolve the issue. I tried different login but that did not work. Then I removed the publish profile on App connect site and that seem to do the trick.


Thanks for sharing this info!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.