iOS build fails when adding device to ad hoc provisioning file

Hi all,

thank you for your great work on expo.

Currently, I’m trying to get my ios build to work with HockeyApp/TestFairy, but it does not seem to work.
My build ID is 03f7d6b3-1373-4ca3-a702-bec7d6584dcc. Can you have a look what’s the issue here?

I let expo handle the creation of certificates and so on. Is there any possibility to use an Ad-hoc Provisioning file with added devices (Is this what the new options --local-auth and --expert-auth are meant for?) or do I have to detach the app to expo kit?

I really would appreciate any help on this.

Hi @dome-ger. We don’t support Ad-hoc builds through exp build right now. If you need an Ad-hoc build you can build a standalone app locally using these instructions:

Hi @jesse. I managed to do this by providing a custom provisioning file executing exp build:ios --expert-auth. It prompted me to provide the path to the provisioning file. I did and everything worked out fine.

Also it seems like it is not possible to run a clean build with exp build:ios -c after having used the expert-auth option. It does not create a new provisioning file anymore.

Ok great! We weren’t sure if expert-auth would work for ad-hoc builds.

@dikaiosune any idea about the second question?

It sounds like exp build:ios -c --local-auth will recreate the profile.

Unfortunately, it does not prompt me to enter the path to the provisioning file and just takes the old one. It did not asked me for anything (Team ID, …).

Upadate: My second try worked out, after the first build took the old file and the build failed.
Build ID: 89dad8db-8dfe-4ca9-862b-14367185f315

exp build:ios -c --local-auth works for me to create the app with ad hoc certificate.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.