iOS build failing?

I’m getting an error when using exp build:ios that I can’t understand.

During the “running gulp task” step:

[16:51:02] Node flags detected: --type
[stderr] /usr/local/Cellar/node/10.4.0/bin/node: bad option: --type
[16:51:02] Respawned to PID: 96210

Then “running archive builder” also fails:

unable to run shell app builder

Here’s my build log:

I’ve built once successfully in the past, and many times with the -t simulator flag set.

Hi –

I’m very sorry. Somehow a build machine that we were testing running node 10 on made it into the production pool and picked up your job.

I think it will work if you try deleting your build job and resubmitting.


1 Like

I’ve tried a few times, how do I go about deleting the job?

I’ve had four bad builds in a row now :grimacing:

Ugh. Oh no. Let me look deeper.

I got one to build!

So glad its worked out. Talking to someone who was working on the build service, it seems like we needed to redeploy to all of the boxes. Sorry for your trouble :frowning:

Hi! I’m really sorry for the effect I had on your day: I caused the problem, and I told Charlie that it was fixed before it actually was. All the builders with with node 10 on them were replaced around when your build succeeded. I’ll be making changes to our builders that should make this sort of problem much harder to cause.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.