iOS build error: codesign ident not present in find-identity

I’m trying to build a new version of my app that’s already in the store. Android build worked fine but getting an error for iOS build, guessing it’s related to certificates. We recently had to renew our Apple Dev license so maybe that caused it?

Here’s the error:

building and signing IPA
saved provisioning profile to temporary path
provisioning profile copied to home directory
done retrieving provisioning profile data
checking if teamID is present in keychain and that certificate is valid...
removed provisioning profile from the home directory
Error: codesign ident not present in find-identity: *******************
Looking for identities matching "(**********)"
     0 valid identities found

    at Object.<anonymous> (/usr/local/turtle-js/node_modules/xdl/build/detach/IosCodeSigning.js:17:13)
    at (<anonymous>)
    at step (/usr/local/turtle-js/node_modules/xdl/build/detach/IosCodeSigning.js:230:191)
    at /usr/local/turtle-js/node_modules/xdl/build/detach/IosCodeSigning.js:230:361
    at <anonymous>

I solved this so updating for anybody else that may run into it, since I found multiple other threads with the same issue but no responses/solution.

I found out my provisioning profile had expired and I think the distribution cert as well since I only saw the push notification cert. So I deleted the push cert and the profile, then ran expo build:ios -c to remove the cached certifications from expo and then chose the option for expo to generate new ones. The build succeeded after that.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.