iOS build crashing

Hi, I’ve built two ios builds for the same app and both are crashing on Testflight. The app opens up the splash page and shows my loading component but fades to black and crashes right after. Not sure what’s wrong since I’ve already built two other iOS apps that were very similar to the one I’m having problems with. I’ve included my app.json and build number below. Thanks in advance.


“expo”: {
“name”: “honeytip”,
“slug”: “honeytip-app”,
“privacy”: “public”,
“sdkVersion”: “32.0.0”,
“ios”: {
“bundleIdentifier”: “com.honeytipllc.honeytip”,
“supportsTablet”: true
“android”: {
“package”: “com.honeytipllc.honeytip”
“platforms”: [“ios”, “android”],
“version”: “1.0.1”,
“orientation”: “portrait”,
“icon”: “./assets/HoneyTip_1024x1024.png”,
“splash”: {
“image”: “./assets/HoneyTip_1024x1024.png”,
“resizeMode”: “contain”
“updates”: {
“fallbackToCacheTimeout”: 0
“assetBundlePatterns”: [“**/*”],
“description”: “Submit and view local tips”

build #: d0122efd-eee3-4827-9943-052cf09a856b

Hey @nethanelkohen,

Can you try running expo start --no-dev --minify to recreate the production JS bundle locally and see if you catch an error when the crash usually occurs?


1 Like

Hey @adamjnav, thanks for the reply. I ran it like you said and am encountering the following error:

Module HMRClient is not a registered callable module (calling enable)

I can’t disable hot reloading so not really sure how to deal with this error or if this is even the error I’m getting on the build. Just fyi - I built an Android APK that works fine.

Also, I’ve deleted all the node modules and restarted the RN packager. I’ve even restarted my computer but still no fix.

Hi sorry for the constant posts – I fixed the hot reloading issues, however, I am not seeing any errors when running expo start --no-dev --minify.

I’m checking in the debugger and the console. Should I look somewhere else?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.