iOS app not showing in notifications settings list

Hi, I’ve had several users recently, all on iOS 12.2 or 12.3, explaining that they do not see our app in the Notifications section of the iOS Settings app.

The app will show on the main screen in the Settings app, but does not display any notification settings on the screen with the header “Allow [app name] To Access”.

Per articles elsewhere, I’ve asked users to quit their Settings app and restart their phone, but that has not solved the issue for them.

Has anyone else experienced this issue?

Thanks.

1 Like

Hey @evanmcd,

This is the first I’ve heard of this. Can you let me know what SDK version your app is?

Cheers,
Adam

Hi @adamjnav, thanks for checking in. I’m on v32. The issue started after I published a new version on the App Store after upgrading from v30 to v32 (I did go to v31 in the middle, but didn’t publish after that update).

Anything else I can provide to help test?

Here’s the app if you want to download it.

Thanks.

Hey @adamjnav, updated to v33 and released on the App Store but still the app does not show in Settings.

I’ve had people update, delete and then update, and of course restart as well but nothing has worked.

We were really hoping the update was going to fix the issue, but now that it hasn’t we’re really in a bad place - we can’t market the app with so many of our initial users having this issue as our app relies heavily on notifications which can not be allowed without Settings available.

Is there anything we can do to troubleshoot this issue?

Thanks.

Evan

1 Like

Hey Evan,

Let me bring this up internally. One more question, is this a Managed project or have you ejected?

Also, one other thing you could try (if you haven’t already) is clearing your credentials and generating new ones with expo build:ios -c to clear the credentials and then generating new ones upon creating a new build via expo build:ios --no-publish. (I added the --no-publish flag as it will prevent you from pushing an OTA update if you don’t want to do so)

Another edit: This post indicates that an app can sometimes not appear until a push notification has been sent through it. Could that be the case here?

Cheers,
Adam

Cheers,
Adam

Thanks Adam. This is a Managed project. Regarding the possibility that it’s only happening for folks that have never received a message I can confirm that that is not the case. At least one of the affected users has received notifications prior to this issue.

Regarding clearing credentials, I’m happy to try that. Would it then require another submission to the App Store or just an expo publish ?

Thanks again for your help.

  • Evan

Hey @evanmcd,

To clear the credentials, you don’t have to publish or submit a new build. Just run those commands I mentioned above which will clear your credentials first and then when you go to build a new build, it will take you through generating new ones that will get added to the Apple Dev Portal. No submission or publishing necessary.

Cheers,
Adam

Hi @adamjnav, I’ve just now tried this but ended up getting a couple of errors. The first was: “Multiple profiles found with the name ‘com.myflocapp.floc AppStore’. Please remove the duplicate profiles and try again.”

I thought that I might have missed a prompt option to name the profile, so I ran the command again but got: “Maximum number of certificates generated”,“userString”:“You already have a current iOS Distribution certificate or a pending certificate request.”

Is it safe to delete the profile manually, then run this command again? Will that solve the issue? Thanks.

Yeah, the automation process can sometimes fail. If it does, it’s always a good idea to go in manually and clear everything yourself to ensure you’re starting with a clean slate.

OK, so I cleared out everything, except the Identifier which Apple said could not be removed because it was in use by the App Store.

I ran expo build:ios -c again and got further in the process, but it ended with:

Encrypted credentials and saved to the Expo servers
Publishing to channel 'default'...
Building iOS bundle
connect ECONNREFUSED 127.0.0.1:19001

Checking the dev portal I see that everything seems to have been recreated (a certificate, a profile, and a key), however the identifier now does not have the Push Notifications capability enabled.

I tried to enable it and link the thing that was just created, but I only am prompted to create a new Apple Push Notification service SSL Certificates.

I feel like I’m now in a worse state than when I started. What would you recommend next?

Thanks.

Hey @adamjnav, just wanted to ping you on this. Do you think I will need to manually setup the certificates, etc. or is there something I can do to get the expo cli to work again?

Thanks.

Hey @evanmcd,

I would try updating the cli to the latest version (if you haven’t already) and then try again. If it doesn’t get resolved, try to manually enable push notifs via the Developer Portal and then create a Push Notification Key (PNK).

Hey @adamjnav, still no luck with that. I’ve got another idea that I’m trying now. I’ll post back here with the results.

OK, so finally figured out the issue. In this case, it was not a matter of the app sending a notification being required before the app appeared in settings, it was whether or not the user had been prompted to allow notifications on that device.

Since we’ve only been asking for notification permissions after registration, users that had an account, but were on a new device were the ones having the issue.

The fix for our app was to add the notifications request to the login flow as well.

Thanks for your help on this @adamjnav. I hope my journey on this helps someone else down the line :slight_smile:

5 Likes

Interesting! I didn’t know that was the default behavior on iOS. Thanks for sharing that information with us. Sorry I couldn’t be of more definitive help haha. Cheers!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.