ios App is not showing infoPlist permission string in app store review and got rejected

Here’s my expo diagnostics log:

Expo CLI 4.7.3 environment info:
      OS: macOS 11.4
      Shell: 5.8 - /bin/zsh
      Node: 15.14.0 - /opt/homebrew/bin/node
      Yarn: 1.22.10 - /opt/homebrew/bin/yarn
      npm: 7.7.6 - /opt/homebrew/bin/npm
      Watchman: 4.9.0 - /opt/homebrew/bin/watchman
      CocoaPods: 1.10.1 - /usr/local/bin/pod
      iOS SDK:
        Platforms: iOS 14.5, DriverKit 20.4, macOS 11.3, tvOS 14.5, watchOS 7.4
      Android Studio: 4.1 AI-201.8743.12.41.7042882
      Xcode: 12.5/12E262 - /usr/bin/xcodebuild
      expo: ^40.0.0 => 40.0.1 
      react: 16.13.1 => 16.13.1 
      react-dom: 16.13.1 => 16.13.1 
      react-native: => 0.63.2 
      react-native-web: ^0.15.0 => 0.15.0 
      react-navigation: ^4.4.2 => 4.4.3 
      expo-cli: 4.7.3
    Expo Workflow: managed

I am using expo-image-picker in one of my expo managed project (SDK 40). Here is my “infoPlist” object in app.json:

"infoPlist": {
    "NSCameraUsageDescription": "This app uses the camera to capture and upload user profile image and listing image.",
    "NSPhotoLibraryUsageDescription": "This app needs access to the photo library to select and upload user profile image and listing image.",
    "NSLocationWhenInUseUsageDescription": "This app usages device location on listing information, Listing search Data and User information."

The standalone build (.ipa) got rejected twice , because it is not showing the text in the permission modal. See the Image apple review team has sent me.

Apple’s recommendation is following:

"Please revise the purpose string in your app’s Info.plist file for the photos to explain why your app needs access.

You can modify your app’s Info.plist file using the property list editor in Xcode."

I tried with a simulator build and it works well. I am really confused now . Can Anybody help me with this? What can I do now? Please help.

are you sure that you are submitting the correct build? if it’s set in a simulator build it will also be set in the app store build.

Yes sir, I am sure that I’ve submitted the correct build. I’ve checked everything very carefully before I submit for second time and got rejected.

One thing to mention sir, in my app while picking image from gallery, the allowsEditing option is set to true. Does it has something to do with this? if I add “NSPhotoLibraryAddUsageDescription” in infoPlist , Is there any chance it to be solved?

you can extract the ipa and verify the info.plist to be certain. test it on testflight with your phone as well to see if it works as expected for you.

Adding “NSPhotoLibraryAddUsageDescription” solved my problem

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.