iOS 13 Compatability

Anyone tried running a standalone Expo app on iOS 13 yet? Considering updating now that the public beta is out, but don’t want the RN app I’m currently working on to be unusable.


Hey @stirman, definitely a smart move to start thinking about compatibility with iOS 13 already. I haven’t tried running on iOS 13 yet personally, but I should mention here that React Native has a tracker open for issues related to iOS 13 and Xcode 11. We might look into opening something similar (not sure yet, though)

1 Like

Good to know! I’ll follow the RN tracker you mentioned. If I do decide to update to 13, I’ll try my Expo apps to see if/what breaks and report back here. Stay tuned :slight_smile:

1 Like

I have tried 2 standalone apps and the Expo app on iOS 13, all 3 applications are crashing so something is not working right :frowning: @charliecruzan @stirman

1 Like

I upgraded to the ios 13 beta & I’ve been using both standalones apps I work on (one ejected, one managed) and haven’t noticed any issues with either of them. They’re both pretty complex apps that use most of the expo APIs.

Great to hear, thanks for sharing!

Expo app itself is crashing for me on iOS 13. So far the iOS 13 beta 2 and beta 3 hasn’t changed that either. The expo app just opens for a moment and then disappears. This is on iPhone XS.

I asked Expo on Twitter about iOS 13 compatibility, since the main Expo app and my new app I’m about to launch(!) are both crashing very quickly after starting them. Someone named Brent with Expo promised that Expo will be compatible by the time iOS 13 is officially launched:

It’d be nice if Expo had a ‘road to iOS 13’ plan we could follow, or beta releases we could use that are approaching compatibility. Or an official announcement would be great.

We will definitely release an announcement once Expo is iOS 13 compatible!


We have an app on Expo SDK 32 still. I tried it on an iPad with iOS 13.0 and it works fine.

The only strange thing I’m noticing is the WebBrowser.openAuthSessionAsync that I previously used is no longer fullscreen. It only opens in a small window and is easily dismissed by accident when tapping anywhere outside the window. Not sure if that’s something iOS is doing or something we’ll be able to control.

Expo app is crashing on ios 13 (beta 4) right after the splash screen shows up for 1 second.

1 Like

Is this happening for anyone else? I read in the Expo SDK 34 blog post that in SDK 34 they’ve patched the issue that causes such crashes. Are you running SDK 34?

I can’t even open the Expo App on iOS 13. I know I upgraded that App recently and it mentioned the support for SDK 34.

Oh, that’s not good. After seeing the blog post I figured I’d give the beta a go but if that’s the case I guess I should wait and save the hassle of having to restore a backup as soon as I upgrade.

Update: I tried the latest public beta and the Expo app is working just fine for me.

1 Like

On iOS 13 beta 4?

I’m running on iOS13 and my (simple) Expo app with SDK33 is working without any issues. AV media (with background audio), Maps and Native Base.

1 Like

Yep. Public beta 4, latest Expo app version, SDK 34. Everything seems fine.

Just want to be clear… When I mention the “Expo app” I’m actually referring to the “Expo Client app” from nametag, not an app built with Expo. Are we on the same page? Sorry if I mislead you guys.

can you try uninstalling and reinstalling the app?

Did that twice.