Invalid format of Android package name but it is valid

I am getting this error when running “expo build:android”. The iOS build worked fine…

Invalid format of Android package name. Only alphanumeric characters, '.' and '_' are allowed, and each '.' must be followed by a letter.

My app.json has this:

"android": {
      "package": "app.ridebeep.App",
      "versionCode": 12,
      "googleServicesFile": "./google-services.json"

There is nothing wrong with my Android package name?! Is this an expo issue?
I realize I probably should not have used a capital A, but it has worked previously and Firebase and Google have my bundle identifer set to “app.ridebeep.App” so I can’t really change it at this point.

  Expo CLI 3.27.10 environment info:
      OS: Linux 5.4 Pop!_OS 20.04 LTS
      Shell: 5.8 - /usr/bin/zsh
      Node: 14.12.0 - /usr/bin/node
      npm: 6.14.8 - /usr/bin/npm
      @expo/webpack-config: ^0.12.16 => 0.12.35 
      expo: ^39.0.0 => 39.0.3 
      react: 16.13.1 => 16.13.1 
      react-dom: 16.13.1 => 16.13.1 
      react-native: 0.63.2 => 0.63.2 
      react-native-web: ~0.13.7 => 0.13.14 
      expo-cli: 3.27.10
    Expo Workflow: bare

I found this commit which make capital letters invalid… Should expo not allow capital letters from now on? Google allows this so I think expo should permit use of capital letters for now.

hey there! i replied in github comment.

one significant problem i see here though is that you appear to have a bare project but you are running expo build:*. this is not supported for bare projects.

yikes, yeah I should definetly go back to managed, I have no reason to have ejected.

1 Like

I am getting the same problem using a managed workflow and after changing the package name to all lowercase. It also worked fine before updating to expo version 39, is there anything else I can check for?

1 Like

me too

What I did was edit the actual expo code in my node_modules folder to be able to temporarily build for android. If you need more details on how to do this, let me know. Nonetheless, I think expo will revert this change they made very soon if they haven’t already yet.

can you share your package names?

i just rolled out expo-cli@3.27.11 as the latest release, this reverts this commit so we go back to the old style of validation. we will need to apply these validation rules to the package name in the future, but we will only add them back once we support applicationId config as separate from package. i am still curious to hear what people’s package names are, though!

In case you didn’t notice the OP did post their package name :slight_smile:

yeah i saw that one, i’m curious to see others as well

1 Like

The issue was with the last part of the name which was: xxx.xxxxxxx.jobtrack.
Perhaps it was too short though since adding a couple letters worked, but the error message said something about capitals and “.” and “/” which I don’t believe were actually an issue.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.