Invalid app specific password error when deploying to app store

When running eas submit --platform ios I’m getting the following error:

:heavy_check_mark: Scheduled iOS submission

Submission details: Log In — Expo

Waiting for submission to complete. You can press Ctrl+C to exit.
:heavy_multiplication_x: Something went wrong when submitting your app to Apple App Store Connect.

We couldn’t figure out what went wrong. Please see logs to learn more.

[logs] Starting iOS app upload
[logs] Downloading archive
[logs] Preparing artifact
[logs] Uploading iOS app to TestFlight…
[logs] Uploading the app with fastlane
[logs] -------------------
[logs] — Step: pilot —
[logs] -------------------
[logs] Ready to upload new build to TestFlight (App: 15XXXXXXXX)…
[logs] Fetching password for transporter from environment variable named FASTLANE_APPLE_APPLICATION_SPECIFIC_PASSWORD
[logs] Going to upload updated app to App Store Connect
[logs] This might take a few minutes. Please don’t interrupt the script.
[logs] Transporter transfer failed.
[logs] Please sign in with an app-specific password. You can create one at (-22910)
[logs] Application specific password you provided using
[logs] is invalid, please make sure it’s correct
[logs] [!] Invalid application specific password provided
[logs] fastlane pilot failed

but I’m pretty sure the password I’m providing is correct. Also tried to re-create it but still the same error. Any ideas what I may be doing wrong?