Installing expo client on simulator keeps failing.

Hi everyone, I’m stuck the error in the following screenshot and I’ve spend half a day searching for fixes, non of things I tried worked (listed below)

  • Update Xcode and the Xcode cli tools
  • Manual install with ‘expo client:install:ios’
  • I’ve made sure my EXPO_DEBUG = true
  • Tried several versions of Node.js (at 10 LTS now)
  • Tried several Expo-cli versions (3.4.0 now)
  • cleared expo cache with ‘expo start -c’
  • Rebooted and erased all Simulator settings several times
  • Rebooted Mac
  • optimised the project with ‘expo optimize’
  • made sure all my assets had the same height x width ratio

The last version update of this app was about 2 weeks ago, I updated with the expo SDK35. So my app would work with the new iOS versions…
Since then I’ve updated only the styles (changed colours, fonts, etc)

I can run the app on my physical iPad just fine…
I need to run on several simulators to make new screenshots for the app so I can publish my app to the store.

Here is my output of ‘Expo diagnostics’:

What am I missing? :’)

Hey @cerenta,

Could you try updating to expo-cli version 3.4.1 and see if the issue persists?



Thanks you for your response. :slightly_smiling_face:
I’ve tried expo-cli 3.4.1 and this issue persists.

I’m still facing the same exact error. Updating Xcode to the newest version as we speak. Hoping maybe it is a simulator issue…

Here’s another update on my versions: (‘expo diagnostics’)


Any help would really be appreciated!

Pretty sure I saw another post here recently with a similar problem where updating Xcode fixed it.

Goo luck!

That worked!
Before the Xcode update I managed to fix it by manually running
xcrun simctl install booted [path to expo client app]
with path leading to a slightly older version of the Expo client.

After the Xcode update the installation worked via the known expo-cli commands.

Now I’m stuck at a frozen Expo client splash screen. :sweat_smile:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.